Details
Students, Staff, and Faculty may receive the “Web Login Service - Stale Request” error when logging into MyPima or Pima services using Single Sign-On (SSO).

Workaround
- Close all tabs or browser windows that are showing the Stale Request error, then try accessing the site again.
- If that does not resolve the issue, follow our Basic Web Browser Troubleshooting - Public guide.
Cause
There can be a variety of reasons you encounter the Web Login Service Stale Request error:
- Session Timeout
- When accessing a website, you are given a limited amount of time to use it. Eventually, that time will expire, and you will be unable to access the website again until you refresh or log back in.
- Faulty Bookmarks
- When bookmarking a page, ensure that you bookmark the website itself, not the login form.
- Internet Connection Quality
- Slow or sporadic Internet can cause this error.
- Other Network Issues
- Because some networks may cause the Stale Request error, try using a different network to log in.