Body
Details
Students, Staff, and Faculty may receive the "Web Login Service - Stale Request" error when logging into MyPima or Pima services using Single Sign-On (SSO).
Workaround
Procedure
- Avoid using bookmarks, try accessing the webpage by typing the URL directly into the address bar.
- Close all tabs or browser windows that are receiving the Stale Request error.
- Clear your browser's cache and cookies, then try again. You may need to restart your browser and/or computer.
- Navigate to MyPima, log out then log back in again.
If you still receive a Stale Request error on another webpage after logging into MyPima, try waiting 15-30 seconds for SSO authentication to complete.
Cause
When you encounter the Web Login Service Stale Request error, there can be a variety of reasons:
- Session Timeout
- When accessing a website you are given a limited time to access it. Eventually, that time will expire and you will be unable to access the website again until you refresh or log back in.
- Faulty Bookmarks
- When bookmarking a page, ensure that you do not bookmark the login form, but rather the website itself.
- Internet Connection Quality
- Slow or sporadic Internet can directly lead to this error.
- Other Network Issues
- Certain networks may cause your browser to display the Stale Request error, try using a different network to log in.